build error fetching loader data : Internal Server Error

PFA the screenshot from vercel

Error: Error fetching loader data: Internal Server Error
03:26:10.408 at Api. (/vercel/path0/node_modules/@plasmicapp/loader-fetcher/dist/index.js:102:15)
03:26:10.408 at ()
03:26:10.408 at fulfilled (/vercel/path0/node_modules/@plasmicapp/loader-fetcher/dist/index.js:47:24)
03:26:10.409 at process.processTicksAndRejections (node:internal/process/task_queues:95:5)
03:26:10.410 > Build error occurred
03:26:10.412 Error: Failed to collect page data for /[[…catchall]]
03:26:10.412 at /vercel/path0/node_modules/next/dist/build/utils.js:1158:15
03:26:10.412 at process.processTicksAndRejections (node:internal/process/task_queues:95:5) {
03:26:10.412 type: ‘Error’

Hi, can you share what is the Plasmic project URL?

@yang please reply

Hi, we’re unable to repro the issue. It publishes fine to this Next.js app (which you can also confirm by choosing Plasmic Hosting in the Publish modal):

Did you follow the Next.js quickstart exactly?

Can you reproduce the issue using a brand new create-plasmic-app, or is it specific to your own app?

Please see Focus mode vs. design mode | Learn Plasmic for more.

I submitted it to Github and then hosting via Github and then chose Vercel to build using that repo. Let me try to redeploy with vercel.

@yang i deleted earlier vercel projects and setup a new project and just tried again and found the same error. please see ss.

How did you create that repo? Can you share the exact steps? Did you do it with create-plasmic-app or did you create it manually yourself?

What if you try this way, which runs create-plasmic-app in a new Github repo?

from your GUI itself.

Just re-pushed to github and redeployed with same error. @yang

Just created a new repo and deployed to that and chose Mode as codegen in the GUI for new github repo creation. Earlier repo was created using Mode as Loader not codegen. This time it’s a different error.

I found something about deleting the .next directory before build but there’s no such dir. @yang, you found some resolution ?
please help me resolve this ASAP :pray:

We’re looking

1 Like

Any updates ?

@alexis_reymann @tom_prest-drawbridge I’m confident @yang and his team shall resolve this today. Cheers.

1 Like

@alexis_reymann @tom_prest-drawbridge @yang and his team identified the issue and the fix will be deployed very soon.