Does scheduled content work in preview mode?

Does Scheduled Content work in preview mode?

Hi Beamer, currently it doesn’t work, could you share more about your use case of preview + scheduled content ?

@efficient_pelican when you say preview mode, are you referring to when you click the green play button in the toolbar in plasmic studio, or are you talking about rendering in your application with preview equals true?

preview == true - i have different hero’s/banners getting ready for black friday/cyber monday and we want to see them in local dev environment

Oooh, sorry about the previous answer, I thought you were referring to studio preview, but scheduled content works with preview:true , all the split options can be used in the dev environment

oh it does? hm it’s not working for me. i don’t have to publish it do i?

No, the only requirement should be to turn it on in the studio (without any publish), are you having issues even with the scheduled content turned on ?

yes i am - let me re check everything

debugging by moving the start time to today

overrides applied

Screen Shot 2022-11-22 at 2.47.15 PM.png

<PlasmicComponent component="Banner" /> in development renders Base

It’s necessary to perform a code setup to make it work currently, as described in

got it yeah i missed this. thank you i’ll poke around

is it possible to hardwire a variation for testing? without setting up the middlware?

You should be able to hardwire it through the globalVariants in the PlasmicRootProvider just like you set any other global variant

do you have an example?

that middleware is throwing this for me

can send repo if you send me your github

i’ve bypassed the error by adding /_next to excludePaths but not seeing content variations

For hardwire you can do the following for example

      name: "Schedule",
      value: "override",