Error when dragging custom components

Getting the following issue when dragging custom components: (Project ID: 8DeEDouUTgxTkvoYdZCCgG)



Thank you for reporting. We’ll look into it

Thank you for your quick response!

Have you tried removing props: {} from the config there? That might be causing the issue. Just a shot into the blue tho.

Well, removing props isn’t allowed. I’ve tried it on other components with props, however, but encountered the same issue.

Thank you for trying to help, though :slightly_smiling_face:

Hey @cute_rodent, could you share the code of your Text component?

@tiago It’s an extremely basic component; all of the components I’ve added in contained the same exact issue.

But, nonetheless, here it is:


Oh, I see. I was thinking this was something related to this specific component. It’s odd that it’s happening for all your custom components, but it indicates that the issue may be related to the app setup. Do you mind sharing your Git repo? Can you confirm this is happening on Chrome? (I see in the logs that the errors are happening on Edge)

@tiago, here is the following code (haven’t set up the repo yet):
Additionally, I can confirm that this error happens on Chrome.

Hey @cute_rodent, thank you for sharing the code. The issue seems to be related to the warning that appears when you load a project using these code components (attached image). After including Plasmic preamble (option 1a in I got the components working properly in studio. Since you’re using create-react-app, you would add the preamble inside <head> in public/index.html. Please let me know if that worked for you!


@tiago Thank you so much!
I was a little confused because of this code snippet:
(it would be amazing if you could add a Create-React-App section that just shows it being added to index.html, as that would greatly reduce confusion)

Thank you for the suggestion! We’ll do it!