Getting an error while building

I’m currently experiencing an error while building:

> Build error occurred
FetchError: invalid json response body at <https://codegen.plasmic.app/api/v1/loader/code/versioned?cb=6&platform=nextjs&loaderVersion=4&projectId=m346pcWog9ZUXF7VoSYrAb%4058.8.0> reason: Unexpected token < in JSON at position 0
    at /Users/thinkingmachines/Documents/Projects/WebsiteRevamp/website/node_modules/node-fetch/lib/index.js:272:32
    at processTicksAndRejections (internal/process/task_queues.js:95:5)
    at async o.fetchLoaderData (/Users/thinkingmachines/Documents/Projects/WebsiteRevamp/website/node_modules/@plasmicapp/loader-fetcher/dist/loader-fetcher.cjs.production.min.js:1:691)
    at async exports.PlasmicModulesFetcher.doFetch (/Users/thinkingmachines/Documents/Projects/WebsiteRevamp/website/node_modules/@plasmicapp/loader-fetcher/dist/loader-fetcher.cjs.production.min.js:1:1887)
    at async exports.PlasmicModulesFetcher.fetchAllData (/Users/thinkingmachines/Documents/Projects/WebsiteRevamp/website/node_modules/@plasmicapp/loader-fetcher/dist/loader-fetcher.cjs.production.min.js:1:1813) {
  type: 'invalid-json'
}

Does anyone have an idea on how to fix it?

could you try publishing again?

tried publishing again still the same error. In context we are using a custom web hook that deploys to our staging environment whenever we publish. Are you looking for a specific log?

I also get this message

{"error":{"name":"UnauthorizedError","statusCode":401,"message":"Missing API token - make sure your plasmic.auth have the 'token' field."}}

when I click https://codegen.plasmic.app/api/v1/loader/code/versioned?cb=6&platform=nextjs&loaderVersion=4&projectId=m346pcWog9ZUXF7VoSYrAb%4058.8.0

We’ve identified the issue; will be rolling out a fix soon!

Should be fixed now; sorry about that and thank you for your patience!

(if it still doesn’t work, please try updating your @plasmicapp/loader-nextjs package)

it works now thanks @chungwu!! :smile: