Plasmic component updates not reflecting anymore on our site

The updates we make to our components on plasmic studio won’t reflect anymore on our website. It’s like it is stuck to a previous version of my project. We tried with the preview mode on and with publishing, to no avail.
When we make a change with preview mode on, plasmic does a “fresh fetch”. But it does not seem to update anything.

We changed our plasmic project name, maybe it’s related to that? Or maybe it’s related to the “missing dependency” issue from yesterday?

It concerns a production website that we urgently need to update


I tried to make some modifications to another plasmic project connected to the same codebase and it won’t work either.

I also tried to bump @plasmicapp/loader-gatsby to 1.0.192 => an error throws at build time (

and 1.0.190 => the issue remains

hmm would you happen to be pinning to a specific published Plasmic project version in gatsby-config.ts? Does this only happen in production or also reproducible locally (with a local gatsby development server)?

No version is specified in gatsby-config.ts
Yes I can reproduce it locally with a dev server

Does this happen in a brand new create-plasmic-app?

I think I know the problem, fixing