Plasmic select library error on focus.

Hi, using Plasmic Select with codegen we are running into an uncaught error while focusing on the select. This occurs even within plasmic studio preview on the select component.

Is this bug coming from the way the plasmic select library uses @react-aria\select\dist\import.mjs?
Or will the fix be in our select component design?

Unhandled Runtime Error
TypeError: Cannot read properties of null (reading 'focus')
Call Stack
node_modules\@react-aria\select\dist\import.mjs (200:0)

Thanks for the help!

Hello @ideological_sloth. Could you please DM me your project ID?

Hey @icaro, any luck sir? :slightly_smiling_face:

Sorry for the delay @parliamentary_trout, still investigating it! :pensive:

I really appreciate your focus on the focus bug :wink:

Hey @ideological_sloth and @parliamentary_trout!
I think I’ve found a solution for your issue. Since you’re using our Select component as a wrapper for your Select (im gonna call this Select2 for now), there are some stuff that can’t be changed in the API/structure of the component.
This issue is happening because the trigger div is marked as not rendered. Can you try wrapping your Select2 component in a div and naming the div trigger and see if that helps?

Interesting. That worked! Thanks for the assist.


This solve worked when we implemented it a couple weeks ago. In the interim, it appears that a new bug was introduced, as mentioned here

Hey @parliamentary_trout. Can you DM me the project and how to reproduce the issue?