Project reporting 500 internal server error

Hey guys! I have a project reporting a 500 Internal Server Error today, despite no changes being done to the project itself. (We attempted republishing it to see if it helped but it did not). If I could get some help ASAP it’d be much appreciated!

The project id is: 76XDWtuf8aB5pjaXByi4un

Hi Amy, following up to see if you’ve made progress with this? happy to help otherwise

Hi @native_woodpecker, when I go to the app host URL, I see this:

The plasmic-host route at the app host URL needs to work in order for the Plasmic project to be open-able. Can you check the app host status? Let me know if that helps.

Hey @yang, @burning_silkworm - the good news is I’ve managed to get the project restored! Bad news is I very much think it was a bug that caused the problem.

To answer your question: We’re using Plasmic within our app, which requires you to be logged in. Since you’re not logged in, it’s spitting back that error. Sorry for the confusion! However, I am confident the app host is fine and not the cause.

Quick timeline of events.

  1. We completed initial work on the problem project on Friday. It had been published, confirmed to be working correctly and was not updated after that point.
  2. Yesterday, I made some large scale changes to a different project that is used as a dependency for the problem project (6VdeyEjjCTtM4jTGJcmay1). These changes included replacing and deleting components.
  3. After I published the changes to the dependent project, the problem project began throwing 500 Internal Server Errors when other staff began to access it.
  4. The problem project was not changed or even looked at before the error started being reported. It was still pointing to the old version of the dependency project and should not have been impacted by the changes made.
  5. When attempting to fix the problem, I tried to both update the dependency project to its latest version (and I’d fix the removed components after). When that didn’t work, I also tried removing it as a dependency altogether. In both cases, Plasmic reported that it put my project in an “invalid state”, and wouldn’t let the action complete.
  6. The workaround that did work was replacing all now deleted components from the dependency project, then updating the dependency once that was done. I was then able to publish a new working version and the problem project was restored.
    My understanding of the problem is that our dependency project changes impacted the broken project even though they shouldn’t have. It’s worth noting the dependency project is used by a couple of other projects and they did not throw the error.

Thank you @native_woodpecker for sharing the play-by-play - super helpful. We’ll see what we can dig into from here.

cc @chungwu @samuel