Unable to run plasmic-host

you can also try to set it for all pages (you can use the <https://studio.plasmic.app> origin instead of * to make it more restrict)

here’s a screenshot from the network tab

can you look at the request to plasmic-host/ to see the response headers?

oh, with a / at the end

I think it’s probably the first request when you open that page

hmmm the headers seem to be all set. Can you now run fetch("<http://localhost:3000/plasmic-host>") from https://studio.plasmic.app and look at the plasmic-host/ request that it makes?

“TypeError: Failed to fetch
at https://studio.plasmic.app/static/js/main.82001da1.js:33:6305870
at :1:1”

can you look at the plasmic-host/ request in the networks tab when you run it?

that request is there because I ran fetch("<http://localhost:3000/plasmic-host/>")

hmmm looks like ERR_BLOCKED_BY_CLIENT usually happens due to some extension such as ad blockes: https://www.keycdn.com/support/how-to-solve-err-blocked-by-client

could that be the case?

if the extensions are disabled in incognito mode, you can try to run that fetch from there (OK to run from studio’s login page)

I turne ublock origin off
and deleted the cache

no difference

also tried it in a private window

is any extension still running?

does it work if you try it from a different browser?

I have originally tried it in Brave and Safari