When going to a page in Plasmic, taken back to homepage

@chungwu when we try to go to a page in the plasmic designer, we are taken back to the “home” (/) page… Unable to access other pages. Multiple people are having the issue
Project: https://studio.plasmic.app/projects/k5wi36LTCNmnJb5rh2sgis/branch/main@latest/page/Home

There is a warning about using outdated packages in our plasmic host, but I have not experienced issues due to that in the past…

Hi I’m looking into this

@insufficient_clam thank you :pray:

I’ve identified the issue and am working on a fix.

@insufficient_clam thank you.

Our builds just broke as well, due to what seems like a new dependency on @plasmicapp/data-sources-context…

If you need a short-term fix to edit a page/component, you’ll need to manually update the URL by typing the name of the page/component in the URL bar. For example:

https://studio.plasmic.app/projects/k5wi36LTCNmnJb5rh2sgis/branch/main@latest/page/IP:%20About

Our builds just broke as well, due to what seems like a new dependency on @plasmicapp/data-sources-context…
This is unrelated, but we are aware of this issue as well. @chungwu to help out on this

@insufficient_clam :+1:

@rear_vole the new dependency issue should be fixed now if you try building again

@chungwu thank you

@chungwu I will once the other issue is fixed. Thanks!

Yeah, not sure if it helps, but I’m unable to access pages with / in name, others seem fine

So I’m guessing special chars are breaking navigation?
PS: typing encoded name in url does not get me to pages, redirects to home always

Yes that’s correct

(The fix has been deployed)