App hosted project no longer rendering artboards

My project stop rendering pages on canvas or showing the elements in the outline. No errors or displayed, just a grey shade on the canvas. Haven’t seen this before. Any suggestions to fix?

Is your project app hosted?


If you open your host in a new window, (localhost/plasmic-host or something like this) do you see a message that it’s ready to be app hosted?

yes - that is all working. And i have added 4 code components that have been working just fine. And haven’t made any changes to them. I just happened to do a refresh on browser window for plasmic and the canvas went gray

i have tried closing browser window, opening new one. logging out and back into plasmic.

stopping my local server, and restarting

No message in the server logs?

no messages in server logs

Is it possible for you to upload your server to a repo so we can help debug this?

yes. give me a couple minutes

Can you test apphosting a new project? I tried this code and it worked fine. Just the background color of the plasmic-host page that needs to be white to not interfere with the canvas background

i can. but how do i get access to the page design in plasmic editor back? I can’t see the other things I put on the page in plasmic?

You should be able to see it. Is the host exactly the same as the github repo? In a new project, can you edit the project as usual?

In all my other plasmic projects I can edit the pages fine. Its just this one project.

And these other projects also uses the same host?

no. oh, i see. you want me to create a new project, and use the same host.

not working in a new project. it says “localhost sent an invalid respons”