Build issue after running Plasmic Fork code

is anybody getting build issue after running plasmic fork code?

Hi @meaningful_sailfish, could you share more details on this issue? What are the steps to reproduce it?

I have forked the plasmic open-source code and after running all the code I am getting this issue while running build script. i.e
when running this script cd platfrom/wab yarn build i am getting this above error

does it still happen after you run git pull and yarn setup-all?

yes it is happening

hmmm it seems to work here, could you share more details so I can reproduce?

more specifically:
• what error do you see when you run yarn dev?
• Do you see any error when you run yarn setup-all?
• Could you share the reproduction steps?

when I am doing yarn dev plasmic app is running on localhost:3003 but on doing yarn build I am getting the error as only one error I am getting when I do yarn setup-all and that is no such directory cd platform/pybackend.

hmmm pybackend is no longer part of yarn setup-all. It should be fixed if you run git pull so you get the latest code

in which branch? I can still see the setup:pybackend script in master branch code and i run yarn setup-all setup:pybackend script also runs as it is in the script

it was updated in the main branch in this commit, which makes setup:pybackend no longer be called when you run setup-all.

Got it now i got no error while running yarn setup-all. Does this fix the issue for build?

Thanks, Victor. Successfully created build but getting one issue when i am running the static build as serve -s build I am getting this

and this error message


Hi @meaningful_sailfish! You can find the documentation on how to run plasmic servers here:

I have followed all the steps and my build was successfully created but unable to serve when I am doing serve -s build. I am getting below error on running build https://localhost:3000. Kindly help me out i am stuck on deployment.

please notice it also includes the instructions for running the servers - instead of serve -s build, you might want to run for example pm2 start pm2-dev.config.js after it’s all set up (see Running Servers using pm2)

can you tell me more specific? i ran pm2 start pm2-dev.config.js (image attached) and after that server -s build still produces the same above issue.

you don’t need to run server -s build - that document should include all commands you need to run. Are you able to open http://localhost:3003/?

Yes i am able to open http://localhost:3003/ and its working. I want to deploy it on my own server