Built-in Select Component not working

For me the Built-in Select Component throws an error when trying to open the options list. It’s just the plain Select Component, nothing changes. Using Codegen with NextJS and App directory.
I really need the Select List :slight_smile:



We’re having issues with select as well, but doesn’t seem to be the same, values simply don’t select :confused:

can you try updating to the latest @plasmicapp/loader-* or @plasmicapp/react-web? and also please make sure you only have one @plasmicapp package in your package.json

I did try latest loader-next (252), no dice.
We have two plasmicapp though:

"@plasmicapp/host": "1.0.107",
"@plasmicapp/loader-nextjs": "1.0.233",

Will try updating both to see if it gets fixed

you should remove @plasmicapp/host and only use @plasmicapp/loader-nextjs

I honestly don’t see how I can only have the “@plasmicapp/loader-nextjs” package without the “@plasmicapp/react-web” package, when the generated component files use the react-web package? When I remove it, it is added back again on plasmic sync…

example imports from the Default TextInput component, it uses react-web and -host packages

interestingly this error only shows up in the plasmic preview mode (via the green play icon), in my codegen project it works.

It’s releated to the @react-aria/focus package:
If you open the file in vscode, even TS complains about potential undefined errors.

I tried removing the focused state variants from the select component, but it didn’t change anything

ah are you using both loader and codegen together? or only codegen? if just codegen, you should remove loader-nextjs

Aahh! Now I understand… I tried to follow the codegen setup after I initialized the project via plasmic studio → github publish and I really had loader-nextjs and react-web in my project.
I’ve cleaned it up and only have react-web now. Also using react-web/lib/host instead of @plasmicapp/host . Now it works!! Thanks :slight_smile: :rocket: