DataProviders render correctly in Studio but not in preview or live site

Hey all, we’re facing an issue with DataProviders where they render completely correctly in the Studio, but not in the preview or on the live site. Has anyone ran into a similar issue?

Has there been any changes here recently in plasmic studio? Based on our troubleshooting the issue is within Plasmic (going to old versions of the site the blogs work until the cache refresh happens for instance). We’ve also rolled back all changes in both plasmic and our repo to a known working version and it’s still broken.

For instance, is supposed to be as it shows up in the studio (attached image). @yang @chungwu

cc @constant_barracuda

Yes, we have a problem with the delivery of props from the Plasmic studio to the built.

Here are the props on Plasmic Studio.

And here are the props on the built.

It doesn’t deliver the children prop. And I have tried to change the name of the prop, it didn’t help.

hi! which page/component should I be looking at in the studio?

ah yes, just found a bug where we are incorrectly dropping the children prop when it’s not registered as a slot type… fixing

Fix has been deployed; could you verify?

Now it works! Thanks!

Great! Sorry about that