Deployment fails with Type error

Getting this error everytime i try to deploy:

Running build in Cleveland, USA (East) – cle1
Cloning []( (Branch: main, Commit: bdd9b5e)
Previous build cache not available
Cloning completed: 4.253s
Running "vercel build"
Vercel CLI 29.3.6
Installing dependencies...
npm WARN deprecated react-scroll-parallax@3.0.0-alpha.14: Package no longer supported. Contact Support at <> for more info.
added 680 packages in 11s
126 packages are looking for funding
  run `npm fund` for details
Detected Next.js version: 13.1.1
Detected `package-lock.json` generated by npm 7+...
Running "npm run build"
> tmp-cpa@0.1.0 build
> next build
Attention: Next.js now collects completely anonymous telemetry regarding usage.
This information is used to shape Next.js' roadmap and prioritize features.
You can learn more, including how to opt-out if you'd not like to participate in this anonymous program, by visiting the following URL:
info  - Linting and checking validity of types...
Failed to compile.
Type error: Type 'Button2Props' does not satisfy the constraint 'CommonProps & HtmlButtonProps & HtmlAnchorProps'.
  Type 'DefaultButton2Props' is not assignable to type 'HtmlAnchorProps'.
    Types of property 'target' are incompatible.
      Type 'boolean | undefined' is not assignable to type 'HTMLAttributeAnchorTarget | undefined'.
        Type 'false' is not assignable to type 'HTMLAttributeAnchorTarget | undefined'.
  14 | }
  15 | function Button2_(props: Button2Props, ref: ButtonRef) {
> 16 |   const { plasmicProps } = PlasmicButton2.useBehavior<Button2Props>(props, ref);
     |                                                       ^
  17 |   return <PlasmicButton2 {...plasmicProps} />;
  18 | }
  19 | 
Error: Command "npm run build" exited with 1
BUILD_UTILS_SPAWN_1: Command "npm run build" exited with 1

Can you try updating to latest @plasmicapp/react-web

How would I go about doing that :sweat_smile:

i just have it going through vercel

You’re using codegen right?

I’m not sure, I just have it set up with Vercel linked to the github repository I haven’t actually like run any commands or anything, just built the website and published it through vercel

ah, you could checkout your github repository and run npm install @plasmicapp/react-web to update to the latest. If you invite plasmicops to the repo, we could help you do it

thank you, I sent the invite. For future reference where do I put the npm command?

i ran the command and pushed to the repo but i’m still getting the same error in the editor

hi! sorry for the delay; I’ve pushed a commit here that should work:

thank you, I appreciate it!