Drag-and-drop not working on artboard

is dragging elements to the artboard working for you guys?

What are you seeing?

I tried to drag but the studio got hanged. Refreshing the studio let me do the other operations but dragging was hanging the studio.
Adding elements by clicking was working.
Other applications and tabs were working fine in my system

That happened to me as well. I tried dragging elements but things would freeze. After refreshing and trying again the issue persisted. What worked for me is just clicking on the element from the sidebar and it would automatically add itself without needing to drag it.

Thanks, we’ll take a look. Does this happen for any elements that you try?

Yes it happens for any of the imported packages, default components, I am on chrome.

Here is a recording https://www.loom.com/share/5ed89c0bf9ab4abf97001b34a1979cfa

We’re trying to repro… Would you mind trying from a brand new Chrome profile, does it do the same thing there?

It doesn’t happen on a new Chrome Profile

Also this side bar isn’t jittering like it was

Could it be one of the chrome plugins I have installed?

Unfortunately seems to be the case… It’s hard for our app to detect issues like this one

Dang ok

even today it is freezing.

@eligible_roadrunner would you mind also trying from a new Chrome profile

sure i will definitely try that and let you know