Error about 'glob 2' after syncing code

ever had a type error about ‘glob 2’? :man-shrugging:

never heard of it before, just changed a little thing in plasmic, synced it down and now I get:

the only thing I found was this inside of package-lock.json

fixed it with

Something unrelated (probably)

I’ve added a .gif to my design. Synced it down. Suddenly I get the message, that
iPhoneProMax.png and ellipse35.svg can’t be found.
Never heared of the latter. Couldn’t be found via plasmics search function either.

I just tried syncing again a couple of times
got this:

The I just removed iPhoneProMax.png from my design. (wanted to replace it with a .jpg anyway)

These screens show what happened next

clicked yes on everything


and now it works again

just wanted to tell you in case it helps

hmm I do see images like “Ellipse 32” under image assets… But this sounds like for whatever reason the plasmic/hub_hub/images/ folder didn’t have the files that the cli expected to see…

@chungwu today I had the issue again, that I was asked to enter Yes a couple of times. So far so good.

But just now, while in plasmic watch, I got it again and got this:

now I can’t run my code because I’m getting module not found for a few components.
to be precise: subcomponents(which I haven’t touched in a while) of one component, where I changed 2 font sizes. (earlier today, where afterwards it was still working)

plasmic sync again and again doesn’t solve the issue

I hope we can resolve this soon. I’m kinda stuck

hmm can you try running plasmic fix-imports?

plasmic fix-imports
plasmic sync --force
npm i -g @plasmicapp/cli

did the trick :slightly_smiling_face: