Error when turning preview to true

Hello everyone!
I’m having issues when turning preview to true
I get this error
Error: Error fetching loader data: Internal Server Error

there isn’t any info I can’t use to know whats going on. everything gets back to normal as soon as I turn it into false

Hi Sebastian, could you share the full init call that is on your code ?


  projects: [

        env.NEXT_PUBLIC_VERCEL_ENV === "production"
          ? "prod"
          : env.NEXT_PUBLIC_VERCEL_ENV === "preview"
          ? "stage"
          : // If not production or staging, then just use the latest
            // published version, regardless of tags

export const PLASMIC = initPlasmicLoader({
  preview: false,

// Code components registration
PLASMIC.registerComponent(Bankrate, {
  name: "BankrateWidget",
  props: {
    // Simple scalar props
    adId: "string",
    campaign: "string",

const DynamicHeadingLevels = Array(6)
  .map((heading, index) => `${heading}${index + 1}`);

PLASMIC.registerComponent(DynamicHeading, {
  name: "DynamicHeading",
  props: {
    level: {
      displayName: "Heading level",
      type: "choice",
      defaultValue: DynamicHeadingLevels[0],
      options: () => DynamicHeadingLevels,
    withDate: {
      type: "boolean",
      defaultValue: false,
      displayName: "Should append date?",
    children: {
      defaultValue: DEFAULT_HEADING,
      type: "slot",

any clues?

Still getting the same after updating nextjs loader

Hi Sebastian, it’s indeed an issue, a fix is going to be pushed for it, I will ping you here when it’s up

Hi Felipe! ok good to know that a- it’s not something I did wrong :rolling_on_the_floor_laughing: and b- you are already working on a fix! thats amazing!

Hi Felipe… any updates on this one?

Is the issue still happening to you ?

well… I haven’t tried. was it fixed?

gonna try later but was waiting to hear back from you since you said you’d post news

@fmota We just ran into the same issue

It started failing 5.5 hours ago. (12:06:13 UTC)
We had a successful build around 3.5 hours ago. (14:11:57 UTC)
And it’s been failing since then.

Hey @conservation_sheep bat signal to @tiago


It’s working for us right now

Do you know what caused the issue?

Nop… didn’t changed anything on our side

it worked at the begining, then it stop working for several days, and then started working again