Issue with React project deployment.

Hi Plasmic team. We’re having some issues with our React project. It’s very similar to @good_orangutan’s issue posted above.
We think is related with TS types, and also with the update of the react dependencies. This is preventing us from deploying stage. We had this issue all day.

Our plasmic studio link;

Please let us know if this is being addressed or if we can do something, we really need to deploy tomorrow.

are you using codegen? could you try installing @plasmicpkgs/react-slick?

hey @chungwu, yes we’re using the codegen approach, i’ve tried installing that package but still not working.

what do you see on line 744 of your PlasmicHomePage.tsx?

make sure your @plasmicpkgs/react-slick is at version 0.0.185

This is line 744, react-slick is at the correct version:

are you using next.js or another framework?

no, just react.

hmm seems to be a bundler issue, but I still can’t reproduce with vite. What’s your vite version?

hey sorry the delay, is v3.1.0

hmm this still works for me. Any chance you can give me access to your git repo?

Hey @chungwu we just gave you access to the repo. It’s important to note that we work under /develop branch. Please let me know if you have any question.

Hi @chungwu just wanted to know if there’s any update on this. We couldn’t deploy yet because of this issue.

Thank you for that. There are several issues for us to fix, but to get you going, please do this:

• In your plasmic sync, instead do plasmic sync -p YOUR_ENTRYPOiNT_PROJECT. This will prompt you to also update a bunch of dependent projects; say yes to them all.
• The above should also prompt you to install @plasmicpkgs/react-slick
• Thereafter, run plasmic fix-imports
Things should work after that. Sorry about that!