Local changes not visible in Plasmic

Another issue. I cannot see changes locally made from Plasmic side, what could be wrong? While I can see change on Plasmic visually if I update a component registered via my codebase.

Basically making copy of my project and trying to connect locally gives me Internal Server Error…

on main one I don’t get error, while on copy I get hardly readable error

Hi, sorry I’m not sure I understand what the issue is.

  1. Do you mean you are using loader, and edits in your plasmic project are not showing up in your local host development server via the loader? Do you have preview mode enabled?
  2. When you make a copy of your project, where are you seeing internal server error?

Sorry for a messed up explanation, but basically you got it right.

Yep, the preview mode is enabled.

I am getting error while trying to launch the project locally. I think it happens in the fetching stage, not sure though.

Can you try to spin up a brand new create-plasmic-app to see if that has the same issue as in your custom codebase? That can help us narrow down the issue


Ok, did it. I get this one now:

Now you can either publish the project or turn on preview: true in your loader

Okay, turned on preview and get the same error on fresh create-plasmic-app.

Very helpful, can you also share what is the Plasmic project URL?

We’ll dig into it


This one is one I talked about, in this one I don’t get this same error, but locally I don’t see changes made from Plasmic - https://studio.plasmic.app/projects/5D4abZbKXiZxVXDXjRoMas

This one is a copy of the same project where we get the error - https://studio.plasmic.app/projects/8276zALT3wqXQAGuym6eWX

@childlike_toucan FYI

We found the issue - a recent change we introduced crashes handling empty code expressions like this:

We are rolling out a fix now (should be live in the next hour), but in case you need to unblock, you can also remove that interaction from the button for now!