Plasmic CMS integration

I find myself in a corner, because I’d like to play with Plasmic CMS, but there seem to be no integration available, and I’d like to avoid the hassle of API coding (coding / debugging time consumption … ).

Here is the screenshot from the Integration tutorial from Plasmic :

Here is what I see …
Capture d’écran 2024-06-28 à 14.25.08

While I have a CMS :

Did I miss something ?

You can refer to Can't Create Item into Plasmic CMS using API - #4 by mouthains

Currently, the Plasmic CMS integration is available via the Plasmic CMS component. For more details, check out the docs and tutorial here: Plasmic CMS | Learn Plasmic

Thanks Papan and Sarah. There must be something I’m missing.
Fisrt I had already watched the video reffered in the link :

The video mentions a previous 'admin panel tutorial which is nowhere to be found :frowning:

Now, here is what I’m doing :

I have my CMS model :

I have designed my form with fields and reffering keys :

I have my IDs :

I have set a generic HTTP integration (since I can see nothing else) with URL provided in PLASMIC CMS API doc :

But here is what I get (though both CMS ID and Model Unique ID are correct) …

Any thoughts ?

Simplified forms work with Postgres integrations. For Plasmic CMS, you would have to manually configure your form by turning off the “Simplified” toggle in Form settings.

OK thanks. I had some progress.
I tried to configure the action, and the GET operation produces results OK.

However, I must be doing something wrong, and lacking the relevant doc, for the POST operation :
I have either a 400 (wrong format, with quotes)

Or a 500 without quotes …

The documentation states that the POST call requires body of format:

 rows: [firstItem, secondItem] 

Can you instead try the following json:

rows: [{nom1: "test", telephone1: "99"}]

Hello Sarah,
Thanks for your reply.
I have tried what you proposed, but I still get a 400 problem with quotes :

Now any attempt to remove the double quotes, or replace them by simple quotes leads to a 500 …

It is possibly the way the json body is formatted. Please send your project id.

Try use “Raw” as shown below:-

Then in the box below use the following format:

“rows”: [

1 Like

Hi papan,

I was afk for a few days.
I struggled a LOT before making it work. Apparently there are two flavors or double quotes.
What did the trick was : {“rows”:[{“data”:{“nom1”:“test”,“telephone1”:“99”}}]}
Capture d’écran 2024-07-12 à 13.44.04

Now I’m stuck there, because while I have the syntax for hardcoded values, I’m unable to to use the JSON (Syntax not found yet) or Form syntax (NOTHING works : whatever I type, I get an error):

And this is just for hard coded values, not to speak of UI fields references, which are nowhere to be found in the ‘SELECT DATA’ popup.
There does not seem to be any documentation to explain the correct syntax, and how to get my UI entries values (or I did not find it).

What leaves me confounded is the fact that all the bits ‘look’ pretty much powerfull, but the learning curve is distressing because I can’t find the way to link thoses bits together …

Can you check the header - [x-plasmic-api-cms-tokens]. Make sure the first part is your CMS_ID then semicolon (“:”) followed by CMS_SECRET_TOKEN as shown in screenshot below:

Thanks for your reply.
As a matter of fact, CMS_ID:CMS_SECRET_TOKEN is correct since the raw method works …

What I’d like to do from here is to replace hard coded values with entry fields values on my form, but I have no clue …

Hi, you will need dynamic values to bind this data. Please refer to Dynamic values | Learn Plasmic and to learn how to do this.

Point to the field you want to have dynamic value and click on it. Then click on the Green circle with ‘thunder’ to choose your dynamic value you want to bind with.


OK, again after a LOT of fiddling (because lack of documentation), I got this to work with a form :

However, I did not succeed in using JSON because of added quotes :

Nor does the Form Encoded produce anything beyond ERROR 500, and complains it gets an object instead of a string (see screenshot above).

As implicitely asked, some documentation / example / tutorial beyond API doc would be nice …