Plasmic publishing not appearing

Hi, we published using Plasmic for hosting yesterday and everything worked fine. Today we’ve tried publishing our changes and they are not appearing at all. It says it was published but we are not seeing the results. This is setup using only Plasmic and all changes were made in the plasmic project.

I’m seeing the same issue @chungwu @yang @icaro - any ideas?

Not sure if there’s an issue with plasmic right now?

This is a plasmic only site, no custom code. We publish changes and don’t see anything even after 10-15 minutes.

can you send me project IDs and the production site where you expect to see updates?


Hi @chungwu thank you for helping us with this.

thanks, taking a look!


Can confirm – also having this issue, Plasmic CMS included! However, things seem to go through if you trigger a redeploy (provided you’re deployed elsewhere)

Hi, was wondering if there were any updates? The client is presenting this at a trade show tomorrow.

Sorry not yet - still looking into it…

I tried duplicating my project and deploying to a new sub domain, that didn’t work either. :sob:

while I’m looking into why the hosting is failing, you could also try deploying to vercel yourself as a temporary workaround:

  1. Create a nextjs repo for your project
npx create-plasmic-app@latest
  1. Upload to github with the github cli
gh repo create
  1. Create a project on and connect to your github repo; it should now build and deploy the project
  2. To pick up additional updates you publish from Plasmic, you can create a deployment hook on vercel, which gives you a url that you can hit to kick off a new build