Plasmic select options not copying

I am getting this error with Plasmic select components.

When I try to copy the select component and put it onto another screen, the option values aren’t copying over as well. I have a lot of different select components with many options so it would take a very long time having to manually create new options for every screen, so it would be greatly appreciated if you could help fix this bug

hmm I can’t replicate this; can you link me?

@chungwu Yes:

hmm it appears at the moment that you are relying on default slot content to populate the options… There is a bug here that we’ll look into, but for now you can work around this by “disturbing” the options (add an option and remove it), which forks it from the default slot content. Then you can copy and paste it like usual.

@chungwu I tried making adding and removing an option to “disturb” but it didn’t work and the options sill wouldn’t copy and paste over.

Do you have any other ideas on how I can fix this error in the meantime? Or have you been able to fix this bug yet on your end?

hmm make sure when you add and remove, you’re not doing it by undoing but actually removing.

@chungwu I tried duplicating an Option and then removing it (not undoing it) and it didn’t work. I also tried adding in a new option altogether so that I can then delete it but that didn’t work either since it threw an error and crashed your system:

ah sorry, I meant like this:

Awesome that worked, thanks