Plasmic Studio layers not loading

plasmic studio is not showing any content in layers when plasmic-host is turned on

this was not a problem in the past

Can you try updating your loader dash next js, or try creating a create-plasmic-app and see if that works, and compare the differences

@yang sorry for the late responds. Hosting works when creating a new app with create-plasmic-app

but in my project HubHub, the app is rendered and the “taking a while to load” message appears

this is how it’s set up:

Would you mind sharing the Plasmic project URL here


I can’t seem to repro the issue, when I copy the project and set its app host URL to a new create-plasmic-app, it always works fine. Can you verify that you see the same?

yes the issue must be with my repo

how can we find out where it might be?

@yang @chungwu
I had a similar problem in the past (the elements in the variant artboards weren’t visible because they were out of bound. pushed down by my app). Where Chung figured out that the root height of my application was set to 100%.

This time is different.
3 days ago I sent you the screenshot where the plasmic studio ui didn’t even render.
At the start of this thread I sent you a screenshot where no elements are shown in the outline.
A moment ago I tried opening plasmic studio again (with the host set to http://localhost:3000/plasmic-host)
in Vivaldi, Chrome and Arc, all showing no elements just like in the first screenshot.
Also tried Brave again, which just shows a white screen + the “too long to render” message as always.

I really hope we can find a way to solve this!

The same problem also exists on another project called StampStamp (ty7Q5pqLXXMda15Ddbkjc8)
It uses the same boilerplate as HubHub but it is simpler.

Chung was nice enough to clone it some months ago and find out the root height issue I mentioned earlier.

Since then I haven’t changed anything regarding hosting.
And the StampStamp projects wasn’t changed at all.

If it’s a localhost issue then try switching off Design Mode, some dev servers don’t handle multiple concurrent connections well and will leave your artboards hanging like that

What server?
What connections?

After a lot of searching I found out that under the View dropdown there is something called design mode which can be turned off.
But that didn’t solve anything.

@yang I’d like to note again that this problem (no elements displayed in the outline) wasn’t an issue before (not sure, maybe 1-2 months ago)
And in the case of the StampStamp project, nothing in the project changed since plasmic hosting was still working.