Plasmic sync requires yarn, not npm.

Hi! In repos that use npm and use cli for plasmic sync, if there are package updates needed, is it possible to use npm instead of yarn?

3 min video showing the issue:
1- everytime I run plasmic sync, the cli requests to install @plasmicapp/react-web with yarn
2- after the yarn install and plasmic sync, the project would not be able run since it can’t detect react types
3- the error in point 2 can be resolved by running npm install, but every time that need to do plasmic sync this 3 step process needs to be repeated and takes several minutes

plasmic sync
Could not detect installed version of @plasmicapp/react-web using yarn2: Error: Command failed: yarn info --json @plasmicapp/react-web
A more recent version of @plasmicapp/react-web >=0.2.177 is required. Would you like to upgrade via "yarn add @plasmicapp/react-web"? (Y/n) y

could you try updating your plasmic.json and adding "packageManager": "pnpm"?

Hi @chungwu thank you for your suggestion, it works without needing to run npm install again!

However, even though the dependencies have been updated, if I run plasmic sync immediately again, plasmic cli continues to request upgrade @plasmicapp/react-web version. And it does not allow selecting “no”.

Checking package.json file, already have dependency “@plasmicapp/react-web”: “^0.2.209”, while the cli requests @plasmicapp/react-web >=0.2.177

what do you see when you run:

pnpm list --json @plasmicapp/react-web

Hi @chungwu this is what is returned when I run the command you mentioned. Maybe there is conflict with another npm package?

"name": "gravity-client-react-web",
"version": "10.2.3",
"path": "/home/andrea/Documents/work/MapMap/client",
"private": false

Hmm I guess that’s why it keeps trying to install it…