Plasmic sync stuck in loop

Hi, I am not being able to plasmic sync, it get’s stuck in a loop asking me to update @plasmicapp/cli

Can you check what your @plasmicapp/cli version is?

Did you install @plasmicapp/cli globally or in your repo? If you mean to install it globally, make sure it’s not in your repo’s package.json or in your node_modules

I can see that the version in plasmic.json is older and it is mentioned in package.json


yarn global remove @plasmicapp/cli
yarn add @plasmicapp/cli

It’s prompting me to upgrade again when trying plasmic sync

I retried removing and I got this error


Hmm OK can you type which plasmic

Or just go ahead with yarn add @plasmicapp/cli

which plasmic gave me the following error and after yarn add @plasmicapp/cli and then trying plasmic sync, getting the same prompt to upgrade


Oh sorry didn’t realize you’re on windows. Can you check what version you have in node_modules/@plasmicapp/cli/package.json


what if you tried ./node_modules/.bin/plasmic sync

nothing like that there

I see plasmic there…

Ah ‘sync’ wasn’t there so I thought it’s not what you were looking for


oh I meant, could you run the command,

> ./node_modules/.bin/plasmic sync

asking me to upgrade antd5, should I say proceed?


tried plasmic sync after that, went back into the loop of asking to upgraade