Pushing to GitHub does not work any longer

I’m trying to push my project to GitHub, but it stays on “Setting up job…” forever without any progress or error notification. It worked before though without any issue. Is there anything I can do to find out what’s causing this?

Hi @marc_bonenberger , would you mind sharing what is the plasmic project URL and what is the repo you are pushing to? We can take a look!

Sorry @yang, I’m rather new to Plasmic, but isn’t the plasmic project URL private? The GitHub repo I’m pushing to is private too. Could I share this information via PM?


I may have found the issue. This is what I see in GitHub.

And here is the possible solution:

I’m not the owner of the private repo so I’ll need to reach out to him.

Since the current owner is not very responsive, I downloaded a zip file from GitHub for all project files and set up a new GitHub repo within our own organisation. While I can now initialise pushing to this repo with Plasmic, it fails during “Syncing Plasmic project…”.

Looking into the GitHub logs, the sync process seems to load tons of node modules leading to a “stdout maxBuffer length exceeded” error.

Do you potentially know how to solve that @yang?

I haven’t seen that error before… Is this repo set up to use codegen instead of the headless api?

You can try running create-plasmic-app locally to create a brand new repo connected to your plasmic project, and then diff between that and your current repo to debug what is going wrong with the current repo. Let me know if that helps.

Hi yang,

We have tried that before, but there is a weird error caused by the Antd dependency when deploying on a new GitHub repo.

I’ll work with another developer to try fixing this error.

Thanks for your help.

Best regards

Are you using codegen? Note that codegen is a more advanced and manual way of using Plasmic, where for instance you need to ensure you are installing antd. Is that the Ant issue you’re seeing?

Yes, we are using codegen. There is a versioning issue with Antd. The weird thing is that it works perfectly from the previous developer’s GitHub repo. But when deployed on another GitHub repo, it shows the following errors:

[16:58:28.522] Running build in Cleveland, USA (East) – cle1
[16:58:28.585] Cloning github.com/Blockshard-io/website (Branch: staging, Commit: 8a06640)
[16:58:29.258] Cloning completed: 672.489ms
[16:58:32.276] Restored build cache
[16:58:32.316] Running “vercel build”
[16:58:32.760] Vercel CLI 28.18.5
[16:58:33.028] Installing dependencies…
[16:58:34.660] npm ERR! code ERESOLVE
[16:58:34.662] npm ERR! ERESOLVE could not resolve
[16:58:34.663] npm ERR!
[16:58:34.663] npm ERR! While resolving: @plasmicpkgs/antd@2.0.7
[16:58:34.663] npm ERR! Found: antd@5.4.4
[16:58:34.663] npm ERR! node_modules/antd
[16:58:34.663] npm ERR! antd@“^5.4.4” from the root project
[16:58:34.663] npm ERR!
[16:58:34.663] npm ERR! Could not resolve dependency:
[16:58:34.663] npm ERR! peer antd@“^4.0.0” from @plasmicpkgs/antd@2.0.7
[16:58:34.664] npm ERR! node_modules/@plasmicpkgs/antd
[16:58:34.664] npm ERR! @plasmicpkgs/antd@“^2.0.7” from the root project
[16:58:34.664] npm ERR!
[16:58:34.664] npm ERR! Conflicting peer dependency: antd@4.24.9
[16:58:34.664] npm ERR! node_modules/antd
[16:58:34.664] npm ERR! peer antd@“^4.0.0” from @plasmicpkgs/antd@2.0.7
[16:58:34.664] npm ERR! node_modules/@plasmicpkgs/antd
[16:58:34.664] npm ERR! @plasmicpkgs/antd@“^2.0.7” from the root project
[16:58:34.664] npm ERR!
[16:58:34.664] npm ERR! Fix the upstream dependency conflict, or retry
[16:58:34.664] npm ERR! this command with --force, or --legacy-peer-deps
[16:58:34.664] npm ERR! to accept an incorrect (and potentially broken) dependency resolution.
[16:58:34.665] npm ERR!
[16:58:34.665] npm ERR! See /vercel/.npm/eresolve-report.txt for a full report.
[16:58:34.665] npm ERR! A complete log of this run can be found in:
[16:58:34.665] npm ERR! /vercel/.npm/_logs/2023-04-22T14_58_33_317Z-debug-0.log
[16:58:34.684] Error: Command “npm install” exited with 1
[16:58:35.443] Deployment completed
[16:58:35.024] BUILD_UTILS_SPAWN_1: Command “npm install” exited with 1