Registered code component not showing up in Plasmic?

I need help. I am registering a custom component for use in plasmic. I am doing this in Code Gen. It is a date picker from Material UI. I already connected the server and it seems that plasmic is serving components from localhost:3000. My project installation syncs properly. I registered the component following the instructions you have on your site by making a registerComponent call in plasmic-host.tsx. I reloaded plasmic but the component does not show up. I need help on this.

Another thing to add is that I have a standard react installation of the project, not the next.js installation.

You need to have a plasmic-host Router entry, to which Plasmic would connect to retrieve your code components.

I followed the instructions. It still doesn’t work. I noticed the instructions are for registering at plasmic-init which is what you have listed at the instructions at for use

with Headless API. On the tab for Code Gen (which is what I’m using) it says to register at plasmic-host.tsx but the code itself is labelled as being from plasmic-init.ts. I tried both, neither work. Can I get a little clarification? If I am using code gen, on a react installation without Next.js, in which file should I register a code component?

I have it registered in plasmic-init.ts with the following code.

name: ‘FakeComponent’,
props: {
children: ‘slot’,
className: ‘string’,
verbose: ‘boolean’
importPath: ‘./components/FakeComponent’,

I have resolved the issue. It seems the registerComponent call should be in App.tsx