"skipFonts" prop not accepted in PlasmicRootProvider for font preloading

Hi, we are using codegen and I want to preload a font with the help of nextjs optimization as described in doc here:

But “skipFonts” is not accepted as props for PlasmicRootProvider.

Hi, are you using the headless API or codegen?

@victor codegen

sorry, we need to update this docs! This step is for loader; for codegen you should update your plasmic.json to fontOpts.scheme = "none" instead


Hi @victor. I’m setting fontOpts.scheme = "none" at plasmic.json root but I’m still getting the fonts imported in codegen.

I’ve already tried deleting Plasmic’s srcDir and plasmic.lock file, then running plasmic sync --yes but I’m still getting the Google fonts import statement at the start of my project’s CSS module.

My CLI version is 0.1.326 . Am I missing something?