Studio is not loading at all

hey guys, my studio now isn’t even loading from signup. As soon as I login I get this unresponsive message

the last few days its been difficult to get more than 5 minutes without crashing

I’ve optimised my computer as best I can and I only have plasmic and 3 google sheets tabs open at one time, yet I’m still not getting the performance I need to work on Plasmic


We have been looking into this for the past few days, but haven’t figured it out yet :pensive: You’re using Brave on mac?

Yes, it seemed to be faster when I had this problem before. However I can switch back to chrome if it makes things more transparent on your side

Could you give it a shot? We’ve been testing it on Chrome; it’s definitely using quite a bit of memory, but doesn’t seem to be dramatically leaking over time :thinking_face:

ok, will do

right from login in Chrome

can you reload? :thinking_face:

Yes, it’s marginally better. I can do maybe 1-2 actions then it crashes. It’s very frustrating. Incan select an element. Make a change, then I’m prompted to wait. I wait, make another change, then prompted to wait then it crashes. Repeat

heres a few views of my activity log, while in Plasmic. I thought it might be helpful. As a note I run a Macbook Air with 8GB of Ram. Not exactly a Powertool, but I have removed almost everything taxing from my computer in order to run plasmic and it’s become marginally better. I can do 3-5 actions without crashing. It seems to be a problem on my end as Ive asked my colleagues if they have been having this issue and they say they have not

:thinking_face: Are your colleagues on similar hardware as you?

No, Asim uses a gaming laptop. And my other engineer is on a power mac

Seems like my lowely MacBook Air isn’t capable of rendering the studio Chris said there might be some hung code in one of our components that is causing the memory leak. But I can’t get in to find out.

I’m guessing at the moment, the best option for me is to try another computer? I’m taking it that there isn’t anything unusual going on from your end?

Is there anyway to delete the bottom 4 projects from my workspace? Upon investigation, I found that there was a bunch of components mounted, or trying to synch. in the ‘code component examples’ arena, that when I deleted them from “mounting” that project, all of sudden the performance of my workspace got (marginally better) I can get 2-3 min without crashing.

I’ve removed them… though not sure how that would help :pensive:

me either. hahahah., I’m trying everything

I just did a full factory reboot and the problem still remains. Is it something in my studio? I’m actually going to try my friends computer, which is a MacBook Pro to see if the problem is still there. But I literally have a brand new computer with nothing on it and it still crashes after 2-3 actions

@quarrelsome_wren Really sorry about this. We have already been digging into this, and will continue to see how we can help with performance.

One idea we had in the meantime was whether you would be open to breaking up apart the project into multiple smaller projects, which will help.

Hey Yang. That could be a solution! I’m nit sure how I would manage it going forward though? I’d have to ask @zonal_mammal. As well, I think a simple solution would be an advisory: systems requirements—don’t use a MacBook Air to build a complex app. Hahahahha. I plan to upgrade my computer in time but if this is a solution in the interim I would be down to try

@quarrelsome_wren as we discussed, we are going to split the project into two parts by now. Separate project for Dashboard application and existing project for marketing pages.

On the existing application that’s having the performance issue, we can remove the unused components that might help improve the performance as well.