Support displayName on props to be more user friendly

Add a “displayName” attribute to props so that prop names can be more user friendly instead of being restricted to js variable name rules. Just like how components have user friendly names with the displayName attribute.

example - showModal would display as Show Modal in the editor ui:

props: {
   showModal: {
     type: 'boolean'
     displayName: 'Show Modal'
     ...

Never mind found out it already works. I think adding the documentation show this attribute under the Prop Metadata > Common Options section for this page would be good: https://docs.plasmic.app/learn/code-components-ref/#prop-metadata