Setting up Plasmic in project.

I’m setting up plasmic (Codegen) in a new project

plasmic init was successful


I think it a tragedy how hard it is to figure out how to setup plasmic with Codegen.
Codegen shouldn’t be treated as an afterthought. imo it deserves it’s own landing page and a better (more segregated) treatment in the docs.

tried a few things: tring it again on a clean start, removing the node_modules folder, installing an older version of react-web, removing this Search svg…
but there is always this type of error:

I think this is a bug. And I hope you can resolve it asap!

How to reproduce it:

in an existing codebase:
plasmic init
plasmic sync --projects bZkmRHqpZgGUTSLe9r3ZuT

to sync plasmic for the first time

I’m using the latest version of the plasmic cli

plasmic sync worked after changing the cli version

but there are no components in my codebase (there should be several)

I made sure I had a clean start again

plasmic init → success

but then:

trying older versions of the plasmic cli pretty much always upgrates to the latest version

that’s… strange… if you use npx create-plasmic-app@latest do you see the error? I could not reproduce

no create plasmic app works

I set up a create T3 app
adding plasmic to it with the steps listed didn’t work

This problem is actually really urgent, as I set this up as a challenge for a candidate I want to hire. Which requires T3 and Plasmic

I just added plasmic to a new create-react-app → works
then I tried adding it to a brand new create-t3-app →

hmm I tried create-t3-app and then plasmic sync with your project, and I still can’t reproduce…

Is there something I could try?