Unable to display data with new table component

I can’t get the new table component to display any data. are there any docs or videos on using it yet?

We are working on this! But you can either add a query on the page data tab and already that, or you can set a dynamic value expression and point to any array of objects. Does that work for you?

Hmm that’s what I was trying to do but the data drop-down on the table component was only allowing me to select “fetched data” as a source rather than a dynamic value. My api returns an object and I want to select the array of objects inside it as the data for the table but cannot seem to do it in the studio ui

Yeah I cannot select a dynamic expression for the Data field in the Rich Table settings. I can select one for Default size, Page size, or Fields but not for Data. I’m actually not clear on the purpose of Fields? How is that related to Data?

Oh strange, yes, we’re not showing the dynamic value hover button there!

But you can click on the (too-dim) ellipsis menu to its right, or right-click on the property to get at this


Yes but try to click it. It doesn’t launch the dynamic value picker modal.

Ben, have you tried adding the data under Page Data?

  1. On the top right side you should see page data.
  2. Then you can add a “Data Fetch”
  3. Then you return to the settings page
  4. Then when you select the Data dropdown under the “Rich Table Props” it should appear with the name of your data set. If you didn’t set it in the previous steps, it should say “remoteData”.
  5. This should allow you see the data.

But I’m also having trouble displaying the data. I can pull it into a field but nothing appears on the rich table

Right, so i’ve done all those steps. The problem is that the table needs an array of objects, but the “remoteData” I set up returns an object with the array of objects inside it (as would most standard rest apis). I need to be able to write a dynamic code expression to select the array before passing it to the table component. I am unable to do this using the plasmic studio ui.

I have the same issue. I’m doing server side paging so my response looks like:

    "count": 7,
    "data": [....],
    "lastPage": 10,
    "page": 1,
    "pageSize": 7,
    "total": 66

I don't think that the data binding on the Rich Table Props is Flexible enough to handle more complex JSON responses.

@yang any plans to support server side paging? I don’t want to bring 1,000s of rows to the client and then have it page on the client.

I can’t get the Rich table props to work even with a simple JSON array response though from my Data Fetch.

        "dateReceived": "2022-12-01",
        "depositAmount": 20,
        "depositToken": "ETH",
        "usdAtDeposit": 22054.54,
        "currentBalance": 10,
        "currentBalanceUSD": 12054.32
        "dateReceived": "2022-01-01",
        "depositAmount": 25,
        "depositToken": "ETH",
        "usdAtDeposit": 22054.54,
        "currentBalance": 27,
        "currentBalanceUSD": 22054.54

Rich Tables looks like it will be awesome but I can’t get it to data bind.

I’m guessing it’s because the Data Fetch still considers your api response to be an object.

I’ve tried having my api return a json array, but the http data fetch feature in plasmic wraps all http responses in an object.

Yes but try to click it. It doesn't launch the dynamic value picker modal.

I have the same issue that @evocative_gorilla reported.

I’ve tried all sorts of things and can’t get the Rich Table Props to bind to any data fetch response.

Yeah @yang @chungwu it doesn’t look like Rich Table Props with JSON from a REST endpoint is working.

It will be great once it is though.

Sorry folks, we are working on a fix here

(For REST API endpoints, using dynamic values is indeed the route, but there are a couple issues here we’re fixing!)

Thanks for confirming the issue!

@yang any progress on this?

Meant to follow up here, we rolled out a fix yesterday!