Unexpected TypeError when opening project.

I’m getting “Unexpected error TypeError: Failed to fetch” when trying to open my project. Normally I can pick up type errors and fix them via Vercel deployment, but that builds fine, so I’m stubbed.

Any help apprecated.

have you tried setting the project url to http instead of https when pointing to localhost? seems like a ssl issue

Yes thats fine:


so did it fix it? in console it shows that it accessed localhost on https

Oh I never changed it. Didn’t realise it was pointing to it in the console strange.

Just tried again and I can see console pointing to https. Yet I c=am pointing to http

Did a hard refresh to clear cache and same issue. Now see just Uncaught (in promise) se: Invariant failed

is this the whole output? because that invariant showed in the previous one too. I once had an issue when I accessed studio with Brave browser, it automatically switched http with https. So it might be worth a try checking with another browser

OK tried safari and got the notification “right now Plasmic only works well in Chrome”

haha okay “worth a try”, so didn’t work. But still, it’s strange. Did you try incognito mode in chrome to bypass extensions? If you set the http, but still getting ssl issues, it looks pretty much like rewriting :confused: also, does http://localhost:3000/plasmic-host work?

can you also check network tab to see what url it fetches? for me it used http


Incognito gives same/similar errors:

http://localhost:3000/plasmic-host/ gives these errors:

I select Network but then what ? Fetch/HHR?

sorry, was away. Actually I selected the “all” tab. But it seems like the http issue is gone. I am actually out of ideas :confused: switching browser worked in my case, I’m sorry

what’s the project ID?

Local host: x7VZoMTkaRPxy26VUXVkvK
Vercel: v6pg4cSsCBGuw6cvHxvPez

Vercel works fine

If I try to duplicate the project, I get an error:


@testy_echidna as you said it appears to be “automatically switched http with https” like your previous project .
And when you say “it looks pretty much like rewriting” do you mean, I need to rebuild a fresh project?